马春杰杰博客
致力于深度学习经验分享!

Ubuntu无法安装高版本NVIDIA驱动

有台机器比较奇怪,只能安装390.25版本的驱动,4xx的驱动都装不了。

每次安装驱动的时候,最后都会提示:

ERROR: Unable to load the 'nvidia-drm' kernel module.

当然,大部分人说是因为打开了BIOS中的安全启动,不过这个对我不成立,我已经关闭了安全启动。

还有人说是因为驱动版本的问题,显然这个也是不成立的,因为同一个安装文件,在另一台同样2080Ti GPU中就可以安装。

经过研究之后发现,是系统内核版本的问题,所以升级了内核就好了,其他内核不清楚,我这里测试的Ubuntu,Linux 4.4.0-141-generic是不行的。当然也不能太高,我试过Ubuntu,Linux 4.15.1-041501-generic,这个内核很多ZFS的特性都不支持。后来选了一个Ubuntu,Linux 4.4.248-0404248-generic内核,解决了。

更新内核之后,安装:sudo apt-get install linux-source

关于如何升级内核以及切换内核可以参考本站文章:

Ubuntu切换系统内核

想切换不同系统内核怎么办?按下面步骤即可: 第一步:查找内核:grep submenu /boot/grub/grub.cfg submenu 'Ubuntu 高级选项' $menuentry_id_...

时间:2020/12/19 分类:Linux 人气:46 评论:0

Ubuntu升级系统内核

由于很多原因,比如兼容更新的驱动程序,需要升级系统内核,下面是步骤,整个步骤还是非常简单的: 转到此处: http://kernel.ubuntu.com/~kernel-ppa/mainline/ ...

时间:2020/12/19 分类:Linux 人气:45 评论:0

 

如果你对这篇文章有什么疑问或建议,欢迎下面留言提出,我看到会立刻回复!

打赏
未经允许不得转载:马春杰杰 » Ubuntu无法安装高版本NVIDIA驱动
华为学生服务器每月仅需9元!

留个评论吧~ 抢沙发 评论前登陆可免验证码!

私密评论

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址(选填,便于回访^_^)

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

切换注册

登录

忘记密码 ?

切换登录

注册